singapore: the smallest big galery
home » forum » Templates » Gap between title and content while php-included

You are not logged in.

  • Index
  •  » Templates
  •  » Gap between title and content while php-included

#1 2010-08-06 12:05:10

BadBo
Member

Gap between title and content while php-included

Hi everyone,
I have a problem when including the external.php.
Between the Title and the Thumbs there is a huge gap which isn't there when run via index.php...
I included the external.php with modern template in my homepage, runs fine, but I don't know where this gap comes from... when I view the source code of the fully loaded page, the gap lies somewhere in this source code:

------------------------------------------------------------

<h2>GALLERY1</h2>
    <h4></h4>

</div>

<div id="sgMain-nav">
    <a href="http://url.tld/gallery.php?gallery=GALLERY2">Vorherige</a> | 
    <a href="http://url.tld/gallery.php?gallery=.">nach oben</a>
    </div>

<div id="sgContent">
    <p class="sgTab">Zeige 1 bis 10 von 24 |  <a href="http://url.tld/gallery.php?gallery=GALLERY1&amp;startat=10">Next 10</a>

----------------------------------------------------------

The gap is between the Main-nav and the content!

I tried to change some values og margin and padding of those elements in the snippet (sgContent, sgMain-nav), but doesn't work...
What can I do to make the gallery look normal?

I hope, someone can help me...
Regards

Offline

 

#2 2010-08-06 19:01:18

DC
Administrator

Re: Gap between title and content while php-included

Give us a link to your actual page please.

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#3 2010-08-07 14:53:25

BadBo
Member

Re: Gap between title and content while php-included

Yeah, sure!

http://web7.server5.6.joserv.de/gallery.php

gallery.php lies in / and has the
<?php include("gallery/external.php") ?>
in it...

I used the style sheet for the rest of my pages too, and made my tutorials section look like the gallery... there's the gap, too...!?

Offline

 

#4 2010-08-07 16:54:59

DC
Administrator

Re: Gap between title and content while php-included

You are using modern thats a very touchy template we do not support it in fact I have pulled it from the Lab as it has many problems in dif browsers. Have you tried another template like FrameIt, have you visited the Lab to see all the templates available?

http://sgal-lab.primaveraphoto.com/

Might want to try as I have yet to see the orig dev who made modern back on supporting that template.

Very cool are you a knife maker?

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#5 2010-08-07 17:38:16

BadBo
Member

Re: Gap between title and content while php-included

Yep, I am wink
I wanted to use this template, I liked the style... If I would decide to use another now, I probably would sit hours/days theming and rewritng the page big_smile
I hope I figure out what the problem is and how to solve that... Can't be that hard... It's just a .css style, man big_smile

Offline

 

#6 2010-08-07 18:00:32

DC
Administrator

Re: Gap between title and content while php-included

Yup and a CSS style based on alignment can be a real nightmare of cross browser issues so thats why I only use CSS for style colors and simple stuff that works cross browser, not  alignment and such.

That template is all CSS so thats not a good thing for compatability sake, and it has many issues.

An I can tell you that template is a complete nightmare with its incompatibilities so I do wish you good luck :-)

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#7 2010-08-07 18:06:57

BadBo
Member

Re: Gap between title and content while php-included

In FF 3.5, the latest Opera and IE delivered with Win 7 it works fine...
Can you name some issues for example?

Why can this gap exist?? There is nothing where it could come from, right?

Offline

 

#8 2010-08-07 18:13:37

DC
Administrator

Re: Gap between title and content while php-included

Its dif for every one, thats the prob it depends how you use it or what you change a small change or just having it in a page can cause it to go haywire we get lots of complaints so it has been pulled.

Try it in older IE6 the text does not even line up at all its ontop not next to and yes many still have and use IE6.

Plus dif res cause it to be a mess, and thats why it has been deemed as higly incompatable based on browser platform and the type of page it is embeded in.

some have said it did not play nice in WP so the problems are dif for each cant realy say but right now your having a prob with it and it may not happen in another template so I say try another and if it does not happen it is prob an issue with moderns CSS.

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#9 2010-08-07 18:36:56

BadBo
Member

Re: Gap between title and content while php-included

What's WP?

btw I've done a comparison of different browsers and on IE 7.0 win xp there is the gap between title and pics gone, but the gap pushed the light grey background to the top... most of the others look the same, but the gap is everywhere big_smile

Offline

 

#10 2010-08-07 18:45:26

DC
Administrator

Re: Gap between title and content while php-included

Check in the CSS as you say it is ok stand-alone.
WP is Word Press.

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#11 2010-08-12 18:13:30

PrimaFoto
Moderator

Re: Gap between title and content while php-included

I see the following:

<div id="sgMain-nav">
    
    
    </div>


it is empty - try getting rid of it.


A Junior Scientist of the SGAL - Lab
http://sgal-lab.primaveraphoto.com

Offline

 

#12 2010-08-13 15:00:53

DC
Administrator

Re: Gap between title and content while php-included

And if that does not work try getting rid of that template :-)
and try another.

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 
  • Index
  •  » Templates
  •  » Gap between title and content while php-included