singapore: the smallest big galery
home » forum » Templates » newer themes and imagemagick: Frame It, polaroid, NEAT2

You are not logged in.

  • Index
  •  » Templates
  •  » newer themes and imagemagick: Frame It, polaroid, NEAT2

#1 2010-01-16 02:01:47

dcrocks
Member

newer themes and imagemagick: Frame It, polaroid, NEAT2

Frame It, polaroid, and neat2 don't seem to work if imagemagick is chosen for thumb creation. The thumb names get a'-1' and '-2' appended to the file names at creation but the view code looks for the simple names and raises an error.

Also, even with GD, I don't get the extra 'surround' elements on Frame It. Is there some other setting or is this version available someplace else?

Offline

 

#2 2010-01-17 23:35:59

dcrocks
Member

Re: newer themes and imagemagick: Frame It, polaroid, NEAT2

Still trying to figure this out. It seems to be related to the use of the 'crop' option in these templates. If imagemagick doesn't get all 4 crop parameters it will generate multiple output images, which seems to be what I am seeing.

Offline

 

#3 2010-01-18 04:35:54

dcrocks
Member

Re: newer themes and imagemagick: Frame It, polaroid, NEAT2

Ok. Am I using old stuff or something. I got the singapore code (10.1) from the sgal.org site and the templates from the sgal.lab.primaveraphoto site. I fixed my problem with imagemagick by putting the definitions for cropX and CropY in the correct place and fixing the syntax. Thumb problem solved. I fixed the problems with Neat2 by correcting syntax errors in album.tpl.php and gallery.tpl.php. And I fixed file path errors in Frame It's image.tpl.php.
  But I still can't get the 'frame' to appear around images in Frame It. I'm now concerned that I am working with old, incorrect, code and am a little tired of debugging this. Is there another place to get this code?

Offline

 

#4 2010-01-20 02:56:20

DC
Administrator

Re: newer themes and imagemagick: Frame It, polaroid, NEAT2

I will have the moderator who worked on that code check it out, so give us a few on that one as I tested Frame It a ways back and it worked fine ... the code on the Lab Site shouldn't be incorrect so I will have to have a look at that shortly.

DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#5 2010-01-20 03:39:36

PrimaFoto
Moderator

Re: newer themes and imagemagick: Frame It, polaroid, NEAT2

@dcrocks,
I'll look into the path issues and get back to you ASAP.
I had done a couple no-no's but we'll fix it up.


And I fixed file path errors in Frame It's image.tpl.php.
  But I still can't get the 'frame' to appear around images in Frame It. I'm now concerned that I am working with old, incorrect, code and am a little tired of debugging this. Is there another place to get this code?

Thanks for you comments and input!


A Junior Scientist of the SGAL - Lab
http://sgal-lab.primaveraphoto.com

Offline

 
  • Index
  •  » Templates
  •  » newer themes and imagemagick: Frame It, polaroid, NEAT2