singapore: the smallest big galery
home » forum » Installation » Uploaded images don't show up

You are not logged in.

#1 2010-07-23 02:51:53

Vladislav
Member

Uploaded images don't show up

Hello
I have got a problem with my singapore gallery, I would really appreciate if somebody can help me

The matter is that the images I upload do not display in the gallery.

Link:
http://ok-ekb.ru/gallery/index.php?gall … D%C5%CE%C1

The message I get:

Notice: Only variable references should be returned by reference in /home/o/okekbru/public_html/gallery/includes/io.class.php on line 123

I am using Russian characters in all the captions, including the titles of the pages, maybe the problem is there.

Thank you

Offline

 

#2 2010-07-25 06:44:22

DC
Administrator

Re: Uploaded images don't show up


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline

 

#3 2010-08-12 18:14:28

PrimaFoto
Moderator

Re: Uploaded images don't show up


A Junior Scientist of the SGAL - Lab
http://sgal-lab.primaveraphoto.com

Offline

 

#4 2010-08-13 14:57:53

DC
Administrator

Re: Uploaded images don't show up

That is because your url contains all types of character crap.

You can try this it fixes some problems where gal was not found

In singapore.class.php
look for this line and comment it out.
desanitize request
$_REQUEST = array_map("htmlentities", $_REQUEST);
   
Replace it with the code block below. 

//DC Fix Desanitize Request ...
    ///////////////////////////////////////////////////
    foreach($_REQUEST as $key => $value) {
    if(!is_numeric($value)) {
    $_REQUEST[$key] = trim(strip_tags($value));
    }
    }
    ///////////////////////////////////////////////////


DC


To code or not to code that is the question?

Did my response help you out? Consider donating by buying me a slice, Whats this? Read More!
http://www.clickcraft.net/slice.php

Offline